JavaJava

64x64
mvn clean package排除指定文件不打包 · 2021-01-04 20:39

通过excludes标签配置需要排除不打包、删除的文件:pom.xml设置descriptors指向一个详细的xml,这里是package.xml,里面通过fileSet来设置文件打包详细配置以及通过exclude排除内容:<plu

64x64
maven--插件篇(assembly插件) · 2021-01-04 20:35

maven--插件篇(assembly插件)发布于 2018-09-011. 简介简单的说,maven-assembly-plugin 就是用来帮助打包用的,比如说打出一个什么类型的包,包里包括哪些内容等等。2. 常见的maven插件ma

64x64
Hls加密设置视频教程 · 2020-12-06 19:49

Hls加密设置视频教程

64x64
HLS视频加密ffmpeg视频切片 · 2020-12-06 18:26

想达到的目的:将一个mp4视频文件切割为多个ts片段,并在切割过程中对每一个片段使用 AES-128 加密,最后生成一个m3u8的视频索引文件;首先准备好一下三个东西:加密用的 keyopenssl rand 16 > enc.k

64x64
bootstrap table设置滚动条 · 2020-12-03 14:25

table设置滚动条代码:min-width代表最少宽度max-height代表最少高度<div style="overflow: scroll"> <table class="table" style="min-hei

64x64
解决java.lang.NoClassDefFoundError:javax/xml/bind/J · 2020-11-17 20:10

使用新的JDK14.0.2、JDK15突然发现原来可以运行的项目突然不能启动了!提示:Caused by: java.lang.ClassNotFoundException: javax.xml.bind.PropertyExceptio

64x64
One or more cycles were detected in the build pat · 2020-11-16 09:44

l2jorg-eclipse报错:One or more cycles were detected in the build path of projectOne or more cycles were detected in the b

64x64
elasticsearch html_strip过滤html 在logstash导入前实现html · 2020-07-08 16:37

html_strip过滤的配置发现无效,问题是es不会通过ik分词器处理过滤html标签:测试代码:PUT l2qq { "settings": { "analysis": { "analyzer": {

64x64
Linux下切换root用户提示Authentication failure错误的解决方法 · 2020-07-05 18:33

出现该提示是说明该用户没有权限创建目录,解决:切换root账号,输入su然后输入root账号的密码即可。如果登陆出错,则修改密码:第一种情况可能是root密码输入错误造成的,再仔细检查一遍是否输入错误第二种是刚安装完,没有设置root用户

64x64
Ubuntu linux vim 修改只读文件 修改Apache2端口号 ports.conf · 2020-07-05 11:46

Apache2端口号 ports.conf" [readonly]比如修改dns文件,vim /ports.conf修改完成后保存是没有权限的,可以使用命令::w !sudo tee %会告诉你一串东西 大致 就是保存了 但是和以前的不

64x64
Workbook wb = new HSSFWorkbook(); 粗体 样式设置 · 2020-07-03 23:36

Workbook wb = new HSSFWorkbook(); 粗体 样式设置package com.rmsClient.util.retireInforExcelOuput; import java.io.FileNotFoundE

64x64
https安装SSL证书,提示显示连接不安全(您与该网站的连接不是私密连接,存在安全隐患) · 2020-06-29 22:33

你的连接不是私密连接攻击者可能会试图从XXX窃取您的信息(例如:密码、通讯内容或信用卡信息)。为避免您的信息失窃,建议您停止访问该页面。您与www.l2qq.com之间的连接采用新型加密套件进行了加密。而且,此页中包含其他不安全的资源。他

64x64
LogStash · 2020-04-27 22:48

校验检查配置文件:./logstash -f ../config/test.conf -t最近项目需要使用logstash直连MongoDB,于是就开始搜索windows下的logstash的mongoDB插件安装,发现网上基本都是基于C

64x64
eclipse 报错解决:IS ACCESSIBLE FROM MORE THAN ONE MOD · 2020-04-22 09:25

eclipse 报错解决:IS ACCESSIBLE FROM MORE THAN ONE MODULE例如:The package org.newdawn.slick is accessible from more than one m

64x64
Ubuntu /Cenos linux上安装Git · 2020-04-16 16:00

在Ubuntu 18.04上安装Git。 现在让我们安装git: sudo apt-get install git使用以下命令来检查已安装的git版本:$ git --versionCentOS下安装Gitsudo yum install